close
プログラミング クラウド Microsoft Azure 情報処理資格 基本情報技術者 IT基礎 応用情報技術者 開発・設計方法 オブジェクト指向 内定者・新人研修 プログラミング基礎 アルゴリズム コンピュータ数学 内定者研修 新人研修 ヒューマンスキル プロジェクトマネジメント プレゼンテーション リーダーシップ 組織マネジメント ネゴシエーション ロジカルシンキング Java UI/UX HTTP JavaScript基礎 情報処理資格 ネットワークスペシャリスト ネットワーク インターネットルーティング応用 IPアドレス データベース応用 SQL応用 パフォーマンスチューニング データベース設計 ER図 概念設計(データベース) 論理設計(データベース) IT資格 Linux基礎 OS・システム基盤 セキュリティ TCP/IP OSI参照モデル データベースセキュリティ ファイアウォール 標的型攻撃 SQLインジェクション ネットワーク基本設計 CCNA Cisco プロジェクトマネジメント資格 情報処理資格プロジェクトマネージャ 情報処理安全確保支援士 人事給与 財務会計 管理会計 簿記 生産管理 在庫管理 ERP バランススコアカード 情報処理資格 ITアーキテクト 情報処理資格 ITストラテジスト 情報処理資格 ITサービスマネジメント 情報処理資格 システム監査 PMBOK® PMP® プロジェクト計画 WBS リスクコントロール ITIL ITサービスマネジメント 要求定義 要件定義 見積手法 ビジネスインダストリ 業種・業界知識 業務知識 提案力 ソフトウェアテスト基礎 情報処理資格 データベーススペシャリスト ハードウェア基礎 外部設計(基本設計) 内部設計(詳細設計) データベース基礎 SQL基礎 RDBMS 物理設計(データベース) C++ Ruby MVC基礎 Webアプリケーション開発 JavaEE Javaプログラミング応用 フレームワーク MVC応用 Spring フレームワーク ソフトウェアテスト応用 テスト手法 JUnit スマートフォンアプリ開発 Androidアプリ開発 C# 基礎 C# 応用 負荷テスト Javaプログラミング基礎 ソフトウェアテスト コーチング メンタリング HTML/CSS サーバー構築 仮想化技術 KVS (NoSQL) アジャイル スクラム ファシリテーション C言語 ITパスポート JSTQB データサイエンス 単体テスト ユニットテスト キャリアアップ インターネットルーティング基礎 パケット解析 LAN構築 データベース データサイエンティスト トレンド 障害対応 インフラ監視 HTTP/2.0 コンピュータサイエンス VPN ネットワーク物理設計 データベース障害 JavaScript モダンJS (Modern JavaScript) 応用 MVS応用 バックアップ/リカバリ 分散処理 Hadoop Hive Python AI 深層学習(DeepLearning) CentOS Linux応用 Zabbix シェルスクリプト Infrastructure as Code Windowsサーバー基礎 内部設計 Docker DevOps Windowsサーバー応用 NginX chef Ainsible ロジカルライティング R テスト自動化 Jenkins Git 継続的インテグレーション (CI) バージョン管理 Vagrant 要求分析 Redmine 継続的インテグレーション(CI) 継続的デリバリー (CD) ヒューマンリソース管理 Web API マイクロサービス コミュニケーション 業務知識/業界知識 マーケティング 語学 AWS 法務 IoT ビジネスマナー OJT 業務効率化 表計算ソフト オフィスソフト コンプライアンス フロントエンド Subversion PHP 関数型プログラミング Laravel モダンJS (Modern JavaScript) 基礎 Android Studio 機械学習 iOSアプリ開発 ぷプログラミング React 次世代高度IT人材 共創 IPA Raspberry Pi Xamarin スクリプト言語 GoF CUI VBA 資格 ビジネス文書 jQuery 研修参加レポート マネジメント OSPF テーブル設計 アンガーマネジメント クリティカル・シンキング PDU 経営改善 Pマーク 問題解決技法 サイバー攻撃 エンジニア 参加してみた エンゲージメントマネジメント 労働関連法 新人育成 ネットワーク構築 情報セキュリティマネジメント デザインパターン リファクタリング マルチスレッドプログラミング ベンダーコントロール Modern JavaScript 冗長化 VLAN インフラエンジニア チームビルディング テストケース リーダブルコード セキュリティ入門 ネットワーク入門 Node.js npm gulp ビルドツール Python入門 冗長化入門 インフラ実機演習 プロジェクト管理 Active Directory ネットワーク管理 コンテナ 正規化理論 Haskell 品質管理 OpenStack シンギュラリティ DBA中級 プロトコル UX 基本設計 FinTech トラブルシューティング 並列処理 見える化 PMO ロジカルコミュニケーション Deep Learning インデックス設計 超上流工程 BGP Excel C-CENT Selenide プライベートクラウド アセンブラ コンピュータ基礎 工数見積 CCENT 法律知識 失敗から学ぶ プロジェクト失敗事例 PDCA プログラミング入門 非エンジニア向け 4Biz DNS セルフマネジメント 片付け術 サーバーダウン サーバー タイムマネジメント GO言語 プロダクトマネジメント プロダクトマネージャ LVS ロードバランサー 負荷分散 仮想通過 犯罪心理学 情報漏えい SEカレッジ導入事例 IT研修制度を聞いてみた CentOS7 開発環境構築 数字力 財務 IT人材 UI Machine Learning Go言語 (golang) データマイニング 統計学 新人教育 やり直し数学 RDB つながる工場 モチベーション WebSocket WebWorker HTML5 CSS3 Bootstrap 微分・積分 システム設計 決断力 LAMP環境 教育研修担当者向け ルーティング Linux入門 図解術 目標設定 試験対策 インタビュー技法 Vue.js ブロックチェーン DHCP 仕掛け学 BSC 財務諸表 自己分析 RIP スタティックルート バッファオーバーフロー DoS攻撃 システム開発 Wireshark パケットキャプチャ 管理職研修 部下育成 文章力 情報システム部門向け プロジェクトリーダー プロジェクトマネージャ 塗り絵 リスク管理 法改定 会社の仕組み Chainer AI人材 会話術 テスト技法 会社規模199名まで 会社規模49名まで 会社規模99名まで アプリ開発 サーバサイドJava 営業知識 Cloud 栄養学 基本コマンド ウォーターフォールモデル ヘルスケア 論理設計 ニューラルネットワーク ハンズオン UML 顧客ヒアリング マウスで学ぶ Apache EC2 Lightsail M5Stack DevSecOps プロジェクト成果 画像認識 チャットポット コマンド レビュー 基本用語 自動構築 LPIC-1 サーバーサイドJavascript キャリア形成 ワークライフバランス インバスケット テック用語 GitHub Windows エディタ 教養 令和時代 RESTful API 物理設計 会社規模300名以上 データモデリング サーバーサイドJava Webサーバー基礎 Webサーバー応用 Watson IBMWatson Learning Topics OS モバイル コンテスト トレーニング手法 アーキテクチャ 人材モデル インフラ CI/CD Infrastructure as a Code チーム開発 制度づくり Special_Intro AI市場分析 研修ロードマップ 仕事術 デジタルトランスフォーメーション 財務分析手法 情報整理 PowerPoint 新しい研修 オンライン研修 見どころ紹介 統計分析 ディープラーニング G検定 情報処理技術者試験 販売管理 C# テスト計画 Linuxサーバー WEBサーバ構築 http/2 Postfix イーサリアム プロジェクト・メンバ 正規化 パケット実験 作業分解 トラブル調査 ネットワーク設計 Windows server 2016 ネットワーク機器 DX 管理職 最新動向 ポストコロナ時代 IoTデバイス マイコンボード センサ サーバー仮想化 仮想ルータ WAN インターネットVPN 若手エンジニア ITプロジェクト 人事面談 DX人材育成 Java基礎 ZAP 脆弱性診断 NWサービス構築 イノベーション・マネジメント ネットワークセキュリティ ストレッチ Google Cloud Platform 不動産業界 テレワーク(WFH) ドリル GCP ( Google Cloud Platform ) システム業界 PMS テレワーク ビッグデータ NoSQL OWASP CentOS8 ネットワーク技術 データ分析 デザインシンキング 保険業界 会議リーダー システムエンジニア 段取り術 プロジェクト原論 文章書き換え術 ノーコード No Code MongoDB Redis Cassandra 運用管理 Windows10 仮想マシン リモートワーク 働き方 生産性 IPSec Office セキュリティマナー ソフトウェア・レビュー ライフハック 新しい働き方 エクササイズ ビジネスモデルキャンバス 状況認識 ストレス 必須コマンド Web 今日わかる きほん 状況把握 意思決定 心の健康 IT書籍 書籍紹介 営業マン 類推法 クラス プロセス指向 PdM 共用 ウェビナーレポート 地方創生 GraphQL CSS OWASP ZAP セキュリティマネジメント 問題解決 ソフトウェア 新技術 雑談力 テスト見積もり Scala Go Rust Relay Cloud AI Kaggle ITエンジニア フレッシャーズ 経営戦略 事業戦略 マインドフルネス 基本情報技術者試験 ニューノーマル プロジェクト会議 メソドロジ 講師インタビュー システム障害 販売管理システム VMware セキュリティ事例 ケーススタディ インターネット通信 ビジネスマン 品質向上 提案 ロジック図解術 バーチャルマシン 対策事例 アスリート 国の動向 アンチパターン リモートアクセス

若手に受けて欲しい ルーティング 実践編 研修コースに参加してみた


2021-03-23 更新

今回参加した研修コースは 若手に受けて欲しいルーティング実践 です。

前回の 基礎編 につづき、実践編です。

若手に受けて欲しい!! ルーティングの仕組み (入門編) 研修コースに参加してみた

すでに基礎編で前提知識は学んでいるので、今回は実践あるのみです。徐々に演習の難易度を上げていきましたが、受講者の方にもちょうどよいレベルだったのか、小気味よくサクサク進み、最終的には全員 OSPF でダイナミックルーティングできました!

普段の業務ではネットワークが繋がらなくなるのは致命的ですが、研修では切れてもよいので、この状態で実機を触る機会は、こういった研修コースでしか味わえないものです。入門的なコースを卒業される方にはとてもオススメです!

では、どんな内容だったのかレポートします!

コース情報

想定している受講者
  • TCP/IP プロトコルの基礎知識があること
  • Windows PC の基本操作とネットワーク設定および通信テストができること
受講目標
  • ルーティングテーブルの仕組みを理解する
  • RIP や OSPF などの代表的なルーティングプロトコルを使用できるようになる

講師紹介

基礎編に続き、今回も自己紹介は簡単な名字の紹介だけですすめる、インフラ系の 新谷 泰英さん が登壇です。

新谷 泰英
新谷 泰英
どうすれば技術を身につけられるか、理解できるか、研究しつづけるインフラ系の人気トレーナー

「教室でしか出来ないことに時間を割きたいので、実機演習中心に進めます」とスタートしました。

使用ルータ

教室で使った機材は Cisco ルータ ( Cisco 1812J ) です。

いつも機材の持ち込み、本当にありがとうございます !!

ルータを起動し、講義なしに早速、演習開始です !!

ルータで 2 つのネットワークを繋げる ~ IP を設定

  • 構築手順の基本は大きいものから設定する (今回ならルータ -> PC の順番)
    • ルータのネットワークアドレスを設定する
      • 192.168.10.0 /24
      • 192.168.20.0 /24
      interface fastethernet 0
      ip address 192.168.10.1 255.255.255.0
      no shutdown ! no をつけるとコマンドを無効化する
      exit
    • PC の IP アドレスを設定
      • デフォルトゲートウェイの設定を忘れずに
  • ping で確認
    • Windows でデフォルトで設定される TTL は 128 なので、 TTL が 127 になっている

なお、コマンドをエディタなどで編集・保存しておくと、コピペで実行すると便利とのアドバイスをいただきました。たしかにエラーが起こっても途中で止まって、これはラクチンです。

コマンド解説

補足として、グローバルコンフィグレーションモードはルータの機器全体に適用されます。

ルータ 2 台で 3 つのネットワークを接続する設定

今度はルータを 2 台繋げてやってみます。ただ 2 台以上になると、途端にレベルが上がりました。

  • 演習中の注意
    • ルータで区切られたものがネットワーク
      • PC 0 台のネットワークもある
    • 途中で繋がらないときは、トラブルシューティングの練習にもなる
      • Windows の場合、エラーをしっかり吐いてくれるので、よく見ましょう

スタティックルーティング

いよいよルーティングテーブルの設定です。まずはスタティックルートで手動でやってみます。

  1. 両方のルータでルーティングテーブルに経路情報を追加
    ip route [宛先ネットワークのアドレス] [経由するルータのアドレス]
  2. ping show ip route で確認
    show ip route ! ルーティングテーブルを確認 -> 繋がっているネットワークの個数とアドレスを確認
    # ip route 192.168.10.0 255.255.255.0 192.168.20.1
    • s 192.168.10.0 が追加されている ( s は Static )

ダイナミックルーティング

続いて、ダイナミックルーティングです。 RIP と OSPF どちらもやってみました。

RIP

  1. Rt 1 で設定
    (config)# router rip
    (config-router)# version 2
    (config-router)# network 192.168.10.0 ! 自分に繋がってるネットワークを設定する
    (config-router)# network 192.168.20.0
  2. Rt 2 で設定
    (config)# router rip
    (config-router)# version 2
    (config-router)# network 192.168.20.0
    (config-router)# network 192.168.30.0
  3. show ip route で確認する
    • r 192.168.20.0 が表示される ( r は RIP )
  4. RIP version 2 を使ったなら、すべてそれで設定する
    • 他のプロトコル、 OSPF と混ぜてもダメ
    • version 2 はサブネットマスク、ブロードキャストに対応

OSPF

  1. Rt 1, 2 でそれぞれ設定 (下は Rt 1 の例)
    (config)# no router rip ! ripを無効化
    (config-router)# router ospf 1
    (config-router)# network 192.168.10.0 0.0.0.255 area 0 ! 0.0.0.255 はワイルドカードマスクの表現
    (config-router)# network 192.168.20.0 0.0.0.255 area 0
  2. show ip route で確認
    • o 192.168.20.0 が表示される ( o は OSPF )

この OSPF を使ったダイナミックルーティングが全員が出来たところで、コースは修了しました。新谷さんも驚くほどのスピードで皆さん完遂です。

まとめ

このコースでは基礎編に続き、実際にルータを使って、繋がるPCやルータを増やしながら最終的にはOSPFでダイナミックルーティングをやってみました。

講義の知識がそのまま実践に繋がったので、基礎編 -> 実践編 と受講すると、身についた感覚が得られたものと思います。

入門レベルをもう卒業したいと思う方には、この演習はとてもよいテストになので、オススメです!!

 

label SE カレッジの無料見学、資料請求などお問い合わせはこちらから!!


SEカレッジについて

午前免除 FAQ

タグ一覧